Forum Index   -   Topic Index
   Miscellaneous
     How To : XOOPS Cube Install and Migration
Register To Post

Threaded | Newest First Previous Topic | Next Topic | Bottom
Poster Thread
gigamaster
Posted on: 2007/4/14 18:01
Home away from home
Joined: 2005/12/30
From: Switzerland
Posts: 1227
How To : XOOPS Cube Install and Migration
There's a good idea on the wiki to achieve these tasks. The wiki provide useful examples and its visually well documented. For example the graphical step-by-step its quite explanatory. Same for compatibility and server applications icons.

XOOPS Cube Install and Migration

To help other users we can share our experience by posting our server config.,
installed modules and any other extension, preload or ajax library.

Example A

Configuration
[os + server + db + php version)
Linux 2.6.17 - Apache 1.3.37 - MySQL 4.0.27 - PHP 4.4.6

Type of Install
XOOPS Cube 2.1 Legacy RC, Fresh install

Modules and Extensions Installed

+ Modules D3 by Gijoe
+ Modules XC by Minahito
+ Preloads by Wanikoo
+ Ajax Library by Roy


This way, we focus on positive feedback and we are acknowledge about what works and consequently what doesn't.


User Contribution

1 - I have installed same modules as config example A
2 - Installed also modules XY and XZ
a) Module XY runs fine
b) Module XZ bugs
3 - XZ fails to run within XOOPS Cube Legacy
a) Module has too much bugs - report it to developer's site
b) The module is not compatible with Legacy - report to SF.net
4 - Add to Wiki - Module Compatibility

Module Compatibility

WIKI : "...for a completed list, we should try to put 1 module to 1 page with the icon indicating the testing result."

Module name

Category............Content management
Module name......ModName
Version..............1.0
Cube version......Legacy 2.1 RC
Web server........1.3.34
MySQL.............4.0.15
PHP..................4.4.0
Download URL...http://www.developersite.com/

It seems quite academic and heavily rhetorically but i think we can turn it visually simple - alike Minahito's graphics for modules compatibility and server apps versions and 'migration'



Any suggestions?
Thanks


----------------
Xoops Cube Support

MAC OSX - Apache 2.2 - MySQL 5.5 - PHP 5.3
Free BSD - Apache 2.2 - MySQL 5.5 - PHP 5.2

minahito
Posted on: 2007/4/16 16:37
Home away from home
Joined: 2005/10/6
From: Japan
Posts: 398
Re: How To : XOOPS Cube Install and Migration
Nice suggestions!

I'm orgnazing the format on your idea, for RC2 release.

Thank you very much.


----------------
minahito
Homepage (poor English )

gigamaster
Posted on: 2007/4/16 16:41
Home away from home
Joined: 2005/12/30
From: Switzerland
Posts: 1227
Re: How To : XOOPS Cube Install and Migration
We can improve usability here for new users contributions and stuff.
By providing links and graphical help to each user operation
we get an intuitive work flow (less academic and rhetorical)


----------------
Xoops Cube Support

MAC OSX - Apache 2.2 - MySQL 5.5 - PHP 5.3
Free BSD - Apache 2.2 - MySQL 5.5 - PHP 5.2

plusangel
Posted on: 2007/4/17 2:13
Home away from home
Joined: 2006/3/8
From: Athens, Greece
Posts: 237
Re: How To : XOOPS Cube Install and Migration
This is my little contribution, for the beginning.
I hope that I choose the correct place.


Configuration
[os + server + db + php version)
wimdows xp(sp2) - Apache/2.0.59 - MySQL 5.0.24a - PHP 5.1.6

Type of Install
XOOPS Cube 2.1 Legacy RC (21rc_snapshot_2007413-1612), Fresh install

Modules and Extensions Installed

+ smartSection 2.13
+ smartFAQ 1.08
+ WF-downloads 3.1
+ myDownloads 1.42 (Herve version)

Success (as far as I've tested) without system module installed.

- PD-downloads I have some notices like

Warning: Cannot modify header information - headers already sent by (output started at C:\wamp\www\rc2\modules\PDdownloads\include\functions.php:978) in C:\wamp\www\rc2\modules\legacyRender\kernel\Legacy_RenderTarget.class.php on line 25

but i feel that is working.

Testing on progress!


----------------
Regards Angelos,

xoopsCube.gr, the greek support site!

minahito
Posted on: 2007/4/17 16:10
Home away from home
Joined: 2005/10/6
From: Japan
Posts: 398
Re: How To : XOOPS Cube Install and Migration
I modify the format a little and write it in this page of Wiki. Well, where should we report to?

- Collects all reports to this topic.
- Asks reporters to write a new topic for each report.

I'll write about that.

And, RC2 will be packaged tomorrow.


----------------
minahito
Homepage (poor English )

gigamaster
Posted on: 2007/4/18 2:00
Home away from home
Joined: 2005/12/30
From: Switzerland
Posts: 1227
Re: How To : XOOPS Cube Install and Migration


Thank you all to take 2 min to contribute !

1 min to check your config
1 min to share your experience

It's easy as Copy and Paste from this Report Examples !

This way, we focus on positive feedback and we are acknowledge about what works and consequently what doesn't.


----------------
Xoops Cube Support

MAC OSX - Apache 2.2 - MySQL 5.5 - PHP 5.3
Free BSD - Apache 2.2 - MySQL 5.5 - PHP 5.2

minahito
Posted on: 2007/4/18 18:18
Home away from home
Joined: 2005/10/6
From: Japan
Posts: 398
Re: How To : XOOPS Cube Install and Migration
RC2 is available now. I report about xoopscube.org again!

xoopscube.org

Configuration
RHEL ES3 - Apache: 1.3.37 - MySQL: 4.0.27 - PHP: 4.4.6

Type of Install
XOOPS Cube 2.1 Legacy RC, English install
[] Clean Install.
[] Upgrade from other 2.1 packages.
[*] Migrate from XOOPS 2.0.16 JP.

Modules and Extensions Installed
+ Modules Legacy package's standard modules.
+ Modules cubeNews (Original news module).
+ Modules TinyD by GIJOE.
+ Modules xhnewbb by GIJOE.
+ Modules Pukiwiki by nao-pon.


----------------
minahito
Homepage (poor English )

plusangel
Posted on: 2007/4/21 18:06
Home away from home
Joined: 2006/3/8
From: Athens, Greece
Posts: 237
Re: How To : XOOPS Cube Install and Migration
xoopsCube.gr local upgrade

Configuration
wimdows xp(sp2) - Apache/2.0.59 - MySQL 5.0.24a - PHP 5.1.6

Type of Install
XOOPS Cube 2.1 Legacy RC, Fresh install
[] Clean Install.
[] Upgrade from other 2.1 packages.
[*] Migrate from XOOPS 2.0.16 JP.

Time approximately
20min (the procedure is fairly smooth - don't be afraid)

Modules and Extensions Installed

success
+ altsys 0.41
+ Contact us (with secureImage 1.6)
+ Partners
+ d3forum 0.49
+ smartSection 2.13
+ smartFAQ 1.08
+ sitemap 1.3
+ pico 1.18

need attention
- pd-downloads 1.2
Working but in debug generates php warnings like

  Warning [PHP]: Cannot modify header information - headers already sent by (output started at C:\wamp\www\newgen\modules\PDdownloads\include\functions.php:978) in file C:\wamp\www\newgen\modules\legacyRender\kernel\Legacy_RenderTarget.class.php line 26
  

- bulletin2 2.04 (GiJOE's hacked verion 007)
when I tried to update it I got a blank page with the
following message:
Quote:

Fatal error: Class 'XoopsBlock' not found in C:\wamp\www\newgen\class\template.php on line 327

the module seems that is working but when I add a block in
the top-page with the recent news - it remains empty
although I have articles published. So I can use it :(

[ADD]I've tried bulletin2 in a fresh installatio (RC2) as
well but I got the same fatal error - so it's not depend
on the migration procedure.[ADD]



This is the test that carried out so far. I felt very happy when I saw xoopCube.gr running on XCL 2.1!!!!


----------------
Regards Angelos,

xoopsCube.gr, the greek support site!

takafumi
Posted on: 2007/4/21 23:32
Just popping in
Joined: 2007/4/21
From:
Posts: 1
Re: How To : XOOPS Cube Install and Migration
This is my first touch(?) to 2.1.
So tried for localmirror while reading wiki.
And I don't know which information is impotant or not.


csfactory.jp(localmirror)

Configuration
[os + server + db + php version)
Windows2000sp4 - Apache 1.3.33(Win32) - MySQL 3.23.58-nt - PHP 4.3.11

Type of Install
XOOPS Cube 2.1 Legacy RC, Fresh install
[] Clean Install.
[] Upgrade from other 2.1 packages.
[*] Migrate from XOOPS 2.0.16 JP.

Modules and Extensions Installed

+ wordboard 1.02
+ Xoops Protector 3.02
+ multiMenu 1.15
+ xhld 3.07
+ myalbum 2.87
+ search 2.00 http://www.suin.jp/
+ waiting 0.95 Ryus
+ ALTSYS 0.41
+ sitemap 1.30 chanoir


+ xwords 0.46
occured known issue and fixed.
Fatal error: Call to a member function on a non-object in D:\xoops\class\module.textsanitizer.php on line 413

http://xoopscube.org/modules/pukiwiki/index.php?XOOPSCubeLegacy%2FModuleCompatibility%2FCommonProblem

+ weblog 1.42
entering admin menu, error occured as follows.
Fatal error: Call to a member function on a non-object in D:\xoops\modules\weblog\language\japanese\admin.php on line 30


+ liaise 1.27
access to module as user, error occured as follows.
Fatal error: Call to a member function on a non-object in D:\xoops\modules\liaise\class\forms.php on line 263


Could I began to row?
plusangel
Posted on: 2007/4/22 1:08
Home away from home
Joined: 2006/3/8
From: Athens, Greece
Posts: 237
Re: How To : XOOPS Cube Install and Migration
In the above installation, when I click to Legacy System > Xoops config (inside the administration area) I got the this screen.

By trying a fresh installation everything is fine. So the problem exists only in migration.


----------------
Regards Angelos,

xoopsCube.gr, the greek support site!

(1) 2 3 »
Threaded | Newest First Previous Topic | Next Topic | Top

Register To Post
 

Who's Online
14 user(s) are online (8 user(s) are browsing Forums)

Members: 0
Guests: 14

more...

Welcome | News | Overview | Documentation | Forum | Tutorialstop
Brasilian | French | German | Greek | Japanese | Korean | Russian | T-Chinese
Powered by XOOPS Cube © 2001-2011 The XOOPS Cube Project