Home > News > Announcements > XOOPS 2.0.15 JP released!

XOOPS 2.0.15 JP released!

2
onokazu
onokazu submitted 2006/6/9 11:30, published 2006/6/9 11:30 | 12036 views
Tags:

The XOOPS Cube Development Team is pleased to announce the release of XOOPS 2.0.15 JP. This is a maintenance release for users of XOOPS 2.0.x JP.

---
Outline
========
This is maintenance release for users of XOOPS 2.0.14 JP to fix some bugs including security problems. It is strongly recommended that all users using any of the previous versions of XOOPS 2.0.x JP upgrade to this latest version.
Please refer to 'Changelog' for details of bug fixes.

Although we still use the term 'XOOPS' and not 'XOOPS Cube' for the release package name, the 2.0.x packages offered by us (xoopscube.org) and the ones by xoops.org are not the same.
It is also a different package from 'XOOPS Cube 2.1' which is in alpha status.


Download and installation
========
Please refer to the download page on this site. If you are upgrading from XOOPS 2.0.14 JP, download the upgrade package XOOPS 2.0.14 JP -> XOOPS 2.0.15 JP, and overwrite the current files on your server with the new ones included. If you are upgrading from XOOPS 2.0.13/2.0.13a JP, download the upgrade package XOOPS 2.0.13 JP -> XOOPS 2.0.14 JP, and overwrite the current files on your server with the new ones included.

Please note that the default setting for the debug option is 'PHP Debug' for a fresh install.


Feedback
========
If you find any bugs, please report it at the Core Development forum on this site.


Changelog (from XOOPS 2.0.14 JP)
===============================
modules/system/mailusers/mailusers.php
- Fixed user message not being sent to PM when over 100 users to send

class/snoopy.php
- Fixed port number always being added to the Host HTTP header

kernel/object.php
class/module.textsanitizer.php
modules/system/admin/tplsets/main.php
install/class/textsanitizer.php
- Fixed reference notice errors

install/language/japanese.php
- Fixed a typo

class/criteira.php
- Added patch for possible SQL injection attack

header.php
index.php
misc.php
- Added patch (of 2.0.14a) for local file inclusion vulnerability

language/japanese/xoopsmailerlocal.php
- Added fix for mail encoding problems in PHP4.4.0/4.4.1



The XOOPS Cube Development Team

Comments (0)

Newest first | Oldest first | Nested view | RSS feed

Trackbacks (0)

Newest first | Oldest first | RSS feed

Votes (2)

Newest first | Oldest first | RSS feed
 

    Welcome | News | Overview | Documentation | Forum | Tutorialstop
    Brasilian | French | German | Greek | Japanese | Korean | Russian | T-Chinese
    Powered by XOOPS Cube 2001-2011 The XOOPS Cube Project